Update: All M.Suite services have been fully operational for nearly two hours, and the cloud provider indicated that they are observing a full recovery across the United States.
Issue Recap: There was a widespread outage from a major cloud provider that began in the early hours of the morning and impacted cloud services across many providers in the United States throughout the day. This outage impacted the M.Suite applications in different ways at different times. Below is a detailed breakdown of today's issues:
M.Folio Document Processing > This issue prevented new documents from appearing in M.Folio > Delayed processing was first experienced at 2:13 AM CT > Some documents began timing out at 2:30 AM CT > Processing delays were resolved at 3:34 AM CT
M.Toolbox Report Generation Slowness & Time Outs > This issue caused widgets to intermittently take a long time to load or time out when generating a dashboard > Errors first reported at 4:22 AM CT > Error rates slowly improved throughout the day, but sporadically appeared until the final error at 3:02 PM CT
Email Delivery > This impacted email delivery for MFA tokens, email subscriptions, and email alerts > First outage lasted from 1:56 AM - 4:20 AM CT > Second outage lasted from 9:28 AM - 12:52 PM CT
Posted Oct 20, 2025 - 21:28 UTC
Monitoring
Report generation within M.Toolbox appears to have fully recovered, with performance returning to the expected operational benchmarks. The M.Suite engineering team is continuing to closely monitor, to ensure everything is running smoothly.
Posted Oct 20, 2025 - 19:35 UTC
Update
Thank you for your continued patience.
We're confirming that all email functions with all M.Suite applications are now fully operational.
We're also observing significantly improved performance with report generation within M.Toolbox, although the performance has not fully recovered to the expected operational benchmarks.
Posted Oct 20, 2025 - 18:59 UTC
Update
Our cloud provider has observed encouraging signs of recovery with the mitigation steps they've taken and are now in the process of expanding those mitigations to include all impacted areas.
As of now, email delivery for M.Suite applications appears to be recovering as we've observed consistent successful deliveries.
Posted Oct 20, 2025 - 17:49 UTC
Update
Our cloud provider has taken additional mitigation steps and is reporting seeing initial signs of recovery.
As of now, we're still observing failed email delivery within all M.Suite applications. Within M.Toolbox, we've observed improved error rates for report generation, although errors are still present.
Posted Oct 20, 2025 - 16:44 UTC
Identified
The cloud provider has identified the root cause and is working on a resolution.
As of now, we're still observing failed email delivery across all M.Suite applications, as well sporadic time out errors in M.Toolbox when trying to generate a dashboard or widget from data that is stored in the M.Toolbox data warehouse.
Posted Oct 20, 2025 - 15:52 UTC
Update
The cloud provider outage is now impacting the delivery of emails. This is preventing emails from being sent from all M.Suite applications. We're continuing to investigate, explore mitigations, and work with the cloud provider to resolve.
Posted Oct 20, 2025 - 15:37 UTC
Update
The cloud provider has implemented mitigations to address the ongoing outage. They are seeing early signs of recovery, but elevated error rates are still present.
Posted Oct 20, 2025 - 14:38 UTC
Update
The M.Toolbox application is continuing to experience sporadic slowness & time out errors due to the ongoing cloud provider outage, specifically when generating a report from historic data. When encountering this issue, we recommend re-submitting the report, as failures are intermittent.
The cloud provider will be issuing their next update by 9:30 AM CT.
Posted Oct 20, 2025 - 14:03 UTC
Update
There is an ongoing, widespread outage from a major cloud provider that began at ~2:11 AM CT and is having a significant impact on cloud services across the United States. Although the cloud provider has made progress in restoring all services, there are still some lingering issues.
As a result, performance has been restored to normal operations for M.Folio & M.Tag which we will continue to monitor, but the M.Toolbox application is continuing to experience sporadic slowness & time out errors due to this ongoing cloud provider outage.
Posted Oct 20, 2025 - 13:30 UTC
Monitoring
We are currently experiencing processing delays due to a cloud provider service outage. We are monitoring the incident and will continue to provide updates.
Posted Oct 20, 2025 - 12:12 UTC
This incident affected: M.Folio, M.Tag, and M.Toolbox.